Zum Inhalt springen

Symbole und Datenbanken


helpmax

Empfohlene Beiträge

Hallo Forumsgemeinde,

 

 

ich bin gaaanz neu hier, arbeite noch nicht sehr lange mit Vectorworks, habe aber jede Menge Erfahrung in unterschiedlichen CAD-Systemen.

Ich habe schon im Forum gesucht, aber keine wirklich befiedigende Antwort auf folgende Frage gefunden:

 

Ich habe mehrere Symbole, denen ich eine vorhandene Datenbank zuweisen kann. Dort kann ich dan auf alle relevanten Einträge vornehmen. Ich habe mir die existierende datenbank schon an meine Bedürfnisse angepaßt. So habe ich einige Felder ergänzt/Umbenannt und Vorgabedaten eingegeben. Bestimmte Felder sind bei allen Symbolen gleich (Hersteller/Typ u.ä) einige Felder sind Symbolabhängig (Farbe/Artikelnummer usw.)

Da ich ein "fauler Hund" bin möchte ich diese Werte ja nicht immer beim setzen des Symbols eingeben, ich würde Sie gerne dem Symbol per se mitgeben. Die Werte die symbolabhängig sind müssen logischerweise in der Zeichnung individuell eingegeben werden.

Das wäre sozusagen das Problem.

Was habe ich bisher gemacht:

-Datenbank angepaßt -läuft-

-in Datenbank Vorgabewerte (die für alle Symbole gleich sind) eingetragen -läuft-

-Symbol mit Symbol ändern (3D) aufgerufen und die restlichen Werte die pro Symbol gleich sind eingetragen -läuft-

 

Wenn ich ein Symbol plazier passiert folgendes:

Das Symbol zeigt unter "Daten" nur die Werte an die als Vorgabewerte in der Datenbank hinterlegt sind...

Wenn ich das Symbol in der Zeichnung bearbeite und mir die Daten anschaue erscheinen auch die symbolspezifischen Werte.

Da läuft doch was schief, oder?

 

Beispiel zur Verdeutlichung:

Bibliothek mit 10 Stühlen, Datenbank Stühle, Hersteller ist bei jedem Stuhl gleich (Vorgabe in Datenbank), Typ Stuhl ist Symbolabhängig und Farbe wäre z.b eine Eigenschaft die ich erst in der Zeichnung festlegen würde.

 

Hat jemand eine Idee oder kann mir das Brett vorm Kopf nehmen.

 

 

Grüße und Danke

der helpmax

Link zu diesem Kommentar

Hallo helpmax

 

Beim Einsetzen eines Symboles werden die Vorgabewerte in die Datenbank geschrieben. Die Felder ohne Vorgabewerte bleiben leer. Um die Werte anzupassen, reicht es das Symbol zu aktivieren und im Bereich die gewünschten Einträge vorzunehmen.

 

Gruss, Marc

Leiter BIM Consulting

ComputerWorks Schweiz

________________________________________

Vectorworks - Führende BIM-Spitzentechnologie und Flaggschiff der Nemetschek Gruppe

Weltweit verwirklichen über eine halbe Million Architekten und Designer grossartige Projekte mit Vectorworks!

Link zu diesem Kommentar

Hallo Marc,

 

Danke für die Antwort...

Genau so hatte ich es vor und es ist ja auch der logische Weg.

Leider bekomme ich eben genau dies nicht hin.

Wie bekomme ich diese Vorgabewerte fix dem Symbol zugeordnet.

Ich habe mein Symbol geöffnet (aus der Zubehörpalette raus, mit Bearbeiten)

Gebe Ihm über die Infopalette unter Datenbanken die Vorgabewerte und speicher das ganze ab (Symbol verlassen)

Wenn ich das Symbol jetzt einfüge sind die gemachten Einträge in der Datenbank weg.

Irgendwo mach ich was falsch, nur wo?

 

Grüße

helpmax

Link zu diesem Kommentar

Hallo helpmax

 

Du gehst wie folgt vor:

- Symbol bearbeiten

- Alles deaktivieren

- Häkchen bei der Datenbank machen und die Datenbankfelder eintragen, welche gleich beim Einsetzen des Symboles ausgefüllt sein sollen.

- Symbol verlassen

- Symbol einsetzen und im Bereich "Daten" der Infopalette die Werte kontrolliern, ergänzen und korrigieren.

 

Gruss, Marc

Leiter BIM Consulting

ComputerWorks Schweiz

________________________________________

Vectorworks - Führende BIM-Spitzentechnologie und Flaggschiff der Nemetschek Gruppe

Weltweit verwirklichen über eine halbe Million Architekten und Designer grossartige Projekte mit Vectorworks!

Link zu diesem Kommentar
  • 2 Jahre später...

Das Thema ist zwar schon alt, nichtdestotrotz habe ich das gleiche Problem.

 

Der zuletzt vorgeschlagene Lösungsansatz erschien mir logisch und ich habe ihn direkt getestet.

Leider funktioniert er nicht... was mache ich also falsch?

 

> Im Symbol ergänze ich ohne Auswahl die Datenbank und fülle alle für das Symbol identischen Zeilen aus

> einige Datenbankfelder werden als Text im Symbol grafisch wiedergegeben

> nach Verlassen des Symbols werden die Textfelder nicht mehr angezeigt

> es wird mir keine verknüpfte Datenbank angezeigt

verknüpfe ich nun die Datenbank mit dem Symbol sind die Voreinstellungen (logisch eigentlich?!) weg und ich müsste von vorne beginnen.

 

Meine konkrete Problematik betrifft Türsymbole (in Wand) denen ich nun ein Türstempel hinzufügen möchte. Je Türsymbol gibt es sich wiederholende Informationen die in eine Türliste geschrieben werden sollen (Tabelle via Datenbank mit exportieren und Einlesen in Türliste via S-Verweis). Der Türstempel im Symbol würde dann Türnummern enthalten, die auch als Text im Symbol sichtbar werden (Datenbankfeld) und weitere individuelle Informationen (Ausstattung ect) enthalten sollen.

 

Weiß jemand, was ich falsch mache, bzw kann mir erklären, wie ich diese Informationen mit möglichst wenig Aufwand umsetzen kann? Bei über 1000 Türen wäre die Zeitaufwendung, auch in der Nachpflege) nicht bewältigbar...

 

(Vectorworks 18, 8GB Arbeitsspeicher, 2,7 GHz Intel Core i5, NVIDIA GeForce GT 640M 512 MB)


Nachtrag:

 

 

fülle ich nun das Feld aus, das mit dem Datenbankfeld verknüpft ist, taucht der entsprechende Text nicht im Symbol auf

Link zu diesem Kommentar

Salü _SL_

 

Geduld du haben musst, junger Padawan. ;-)

 

Ich habe es kurz aufgebaut und bei mir funktioniert folgende Vorgehensweise:

 

- Datenbank erstellen -> Manche Textfelder mit Vorgabewerte, manche ohne

- Symbol anlegen

- Symbol bearbeiten -> alles deaktivieren und über den Reiter "Daten" in der Infopalette die Datenbank verknüpfen

- Je Datenbankfeld ein Textblock einsetzen

- Textblock einzeln anwählen -> Menü ändern -> Symboltext mit Datenbank verknüpfen

(Nun werden die Textfelder welche bereits Vorgaben enthalten gleich in das entsprechende Textfeld geschrieben, die anderen bleiben leer.)

- Symbolbearbeitung verlassen

- Symbol aktivieren -> In der Infopalette unter "Daten" erscheint nun die Datenbank -> diese mit einem Klick aktivieren (falls nicht schon automatisch geschehen)

- Nun können die Datenbankfelder beschrieben werden und der Text passt sich im Symbol dementsprechend an

 

Gruss KroVex

CADNODE.ch

Lassen Sie uns gemeinsam effiziente und innovative CAD-Lösungen für Ihr Projekt finden!

Have you tried to turn it off and on again?
Vectorworks | Architektur | macOS/Windows

Link zu diesem Kommentar

Hey!

 

 

Danke für Eure Hilfe, herbieherb du hattest Recht, ich hatte das Symbol ursprünglich über die Konstruktionsebene mit der Datenbank verbunden.

Mithilfe des Zauberstabes und Menü > Ändern konnte ich alle Symbole "aktualisieren"

 

 

Vielen Dank!

Und ja KroVex, bin da durchaus etwas ungeduldig ;)

Link zu diesem Kommentar

Erstelle ein Benutzerkonto oder melde Dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde Dich hier an.

Jetzt anmelden
  • Forenstatistik

    • Themen insgesamt
      23,2Tsd
    • Beiträge insgesamt
      118,9Tsd
×
×
  • Neu erstellen...