Zum Inhalt springen

2D Objekte in Layoutfenster gerendert


3DScheffe

Empfohlene Beiträge

Hallo Forum,

 

VW bietet die Option, 2D Objekte (z.B. einen Lageplan mit einfachen Linien) in einem Layoutfenster mit 3D Ansicht mitzurendern. Ich möchte Teile eines "Stadtmodells" wie 3D - Bausteine auf den sichtbaren 2D- Lageplan stellen. Allerdings zeigt das Ansichtsfenster nach dem Rendern die 2D Objekte (Linien) mal an, mal nicht. Ich habe festgestellt, dass ich weit wegzoomen muss, damit die Linien gezeigt (mitgerendert?) werden. Allerdings sind die sonst feinen Linien dann nur sehr grob gerastert.

Weiß jemand Rat?

Danke vorab!

Gruß

3DScheffe

.....................................................................................................

Windows 7 Pro, Intel i7 CPU, 6GB RAM, VW 12,5 Arch/Land

Apple Powermac 10.8.5, VW 2012 (engl.)

Link zu diesem Kommentar

Hallo 3DSchefe

 

Welche Auflösung hast du für die Layoutbene gewählt? Bei einem Beispieldokument mit einem Lageplan in Form eines Bildes und einem planaren Achsraster darüber, sieht man bei mir die Beschriftung der Achsen ab 600dpi einigermassen gut.

 

Gruss, Marc

Leiter BIM Consulting

ComputerWorks Schweiz

________________________________________

Vectorworks - Führende BIM-Spitzentechnologie und Flaggschiff der Nemetschek Gruppe

Weltweit verwirklichen über eine halbe Million Architekten und Designer grossartige Projekte mit Vectorworks!

Link zu diesem Kommentar

Hallo Marc,

 

Bsp Foto siehe anbei. Ich habe mit 150 dpi gerendert. Ich dachte auch zuerst an die Auflösung, aber daran liegt es wohl nicht. Bei gleicher dpi - Auflösung und reinzoomen sind alle 2D Objekte weg, wenn ich ganz weit wegzoome, kommen die Linien beim Rendern wieder, sind aber sehr grob - egal mit welcher Auflösung.

 

Habe probehalber mal probiert, alle Linien des 2D Lageplans in 3D Polygone umzuwandelne, aber dann vervielfacht sich die Renderdauer und die Linien bekommen eine ganz andere Qualität - z.B. auch keine LInienstärken mehr.

 

Schon sehr komisch irgendwie.

temp.thumb.png.41514e13299bd6a4b2b912a8ff98a753.png

Gruß

3DScheffe

.....................................................................................................

Windows 7 Pro, Intel i7 CPU, 6GB RAM, VW 12,5 Arch/Land

Apple Powermac 10.8.5, VW 2012 (engl.)

Link zu diesem Kommentar

Hallo Forum,

 

Ich habe hier noch 2 weitere Screnshots meines Problems gepostet. Einmal werden die 2D Objekte (planare Objekte) sehr grob gerendert (ohne das die Auflösung geändert wurde, Bild "Ohne Titel.jpg"), einmal wird nur ein teil sichtbar gerendert (Bild "Ohne Titel_2.jpg"), der Rest entfällt. Ich verstehe das nicht und mir ist unklar, wie man das steuern kann.

Weiß jemand Rat?

241406445_OhneTitel.jpg.d922d6ae9b08c3a6f8b51705705e8826.jpg

1573553044_OhneTitel_2.jpg.f7f64fc948d9a6a6bbde82e7914d23c0.jpg

Gruß

3DScheffe

.....................................................................................................

Windows 7 Pro, Intel i7 CPU, 6GB RAM, VW 12,5 Arch/Land

Apple Powermac 10.8.5, VW 2012 (engl.)

Link zu diesem Kommentar

Hallo 3DScheffe

 

Kannst du die Datei ins Forum posten oder einen Auschnitt davon?

 

Gruss, Marc

Leiter BIM Consulting

ComputerWorks Schweiz

________________________________________

Vectorworks - Führende BIM-Spitzentechnologie und Flaggschiff der Nemetschek Gruppe

Weltweit verwirklichen über eine halbe Million Architekten und Designer grossartige Projekte mit Vectorworks!

Link zu diesem Kommentar

Du renderst mit Renderworks (Gipsmodell?)

 

Das was an den RW Renderer (Cinema Engine) geschickt wird, wird wohl das Selbe

sein wie das was per C4D Export exportiert wird.

Mir ist aufgefallen das sämtliche 2D Geometrie nur als, schlecht aufgelöste, Bildtextur

exportiert wird und auf eine Fläche gerendert wird.

Sieht ziemlich so aus wie bei Dir.

(Bei FBX werden alle 2D Elemente gleich komplett weggelassen)

 

Da ich eventuelle 2D Elemente, wenn, ja als Geometrie im 3D brauche, konvertiere ich

diese gezwungenermassen vorher immer in 3D Polygone. Die kommen an.

(Sind aber gegenüber 2D Elementen leider in VW unkomfortabel zu bearbeiten)

 

Deshalb habe ich noch nie versucht ob es einen Weg gäbe diese grob aufgelösten

Texturen irgendwie in besserer Qualität heraus zu bekommen.

 

 

Du könntest aber das Selbe tun.

Gib Deine 2D Geometrie per Ansichtsbereich als hochaufgelöste Bilddatei aus und

bau Dir daraus ein RW Material das Du auf einen Quader als Untergrund anwendest.

Das Planmaterial wird dann in der selben Auflösung wie die 3D Geometrie gerendert.

(Wie wenn Du z.B. eine schöne hochaufgelöste Fussbodentextur verwenden würdest)

 

Das wäre auch der Weg wie man es sonst in einem normalen 3D Programm wie C4D

machen würde.

 

 

Das andere wäre, eine Kopie der 2D Geometrie in 3D Polygone umzuwandeln.

Ggf. lässt sich das, unter Kontrolle der Strichstärken (?), auch rendern.

📦 Mac Mini M1 16 GB M1  macOS 14 Sonoma PB

🗑️ Mac Pro 6c 24 GB D700  macOS 12.5 Monterey, in Rente ...
📺 PC RYZEN 3950X 64 GB RX6800 16 GB  🐧 Manjaro + OpenSUSE Tumbleweed + ElementaryOS
VW 2023 ARCH US
🇪🇺 Europe

Link zu diesem Kommentar

Danke sehr für Eure Tipps!

 

@ Marc: Erklärende Fotos siehe Vorgängerpost!

@ Zoom: Danke für die Tipps. Ich habe das einmal mit den 3D Polygonen probiert. Hat prinzipiell funktioniert. Das einzige Problem war, dass nun die Linienstärke nicht mehr gerendert werden kann - ganz gleich wie dick die Strichstärke des 3D Polygons eingestellt war. Es kommen immer haarfeine Linien im Rendering heraus, die man kaum sieht.

Ich werde das mal mit dem 3D Material probieren, das man auf einen Quader projiziert. Vermutlich wird es nur kniffelig, dass das Material (=Foto) genau die richtigen Abmessungen hat, damit die Größe im Rendering stimmt und die Linien an der richtigen Stelle sind.

 

Nochmals Danke.

Gruß

3DScheffe

.....................................................................................................

Windows 7 Pro, Intel i7 CPU, 6GB RAM, VW 12,5 Arch/Land

Apple Powermac 10.8.5, VW 2012 (engl.)

Link zu diesem Kommentar

Hallo 3DScheffe

 

Kannst du die Datei ins Forum posten oder einen Auschnitt davon?

 

Die Screenshots zeigen zwar, dass das Resultat nicht wie gewünscht ist, aber ich kann daraus keine seriösen Tipps geben oder eine detaillierte Analyse durchführen. Du kannst die Datei natürlich auch dem HelpDesk von Computerworks senden.

 

Viele Grüsse, Marc

Leiter BIM Consulting

ComputerWorks Schweiz

________________________________________

Vectorworks - Führende BIM-Spitzentechnologie und Flaggschiff der Nemetschek Gruppe

Weltweit verwirklichen über eine halbe Million Architekten und Designer grossartige Projekte mit Vectorworks!

Link zu diesem Kommentar

Sollte nicht knifflig werden.

Beim Material gibst Du ja links unten die Grösse der Textur an.

Bei Dir vielleicht so etwa wie 1200 m.

 

Soweit ich es sehe beginnt RW immer von irgendeiner Ecke, je Körper.

(Also wenn mehrere Körper per die Klasse das selbe Material bekommen,

kann man das Material nicht gleichzeitig für alle Körper ausrichten)

Zur Not muss man das mit dem Mapping Tool manuell hinschieben.

Denke aber das ist in dem einfachen Fall gar nicht nötig.

 

 

Nur der grosse Hammer der mir neulich auffiel.

RW kann nur quadratische Texturen !!!1!!elf!

 

Wenn man eine Rechteckige Bildtextur verwendet, verzerrt er sie zu einem Quadrat !

(Mein Lochblech :@ )

Du muss also am besten eine Quadratische Textur des Lageplans raus speichern.

Zumindest bei Map Typ Perimeter. Du kannst aber mal mit den anderen Mapping Typen

im OIP > Render, des Objekts herum probieren.

📦 Mac Mini M1 16 GB M1  macOS 14 Sonoma PB

🗑️ Mac Pro 6c 24 GB D700  macOS 12.5 Monterey, in Rente ...
📺 PC RYZEN 3950X 64 GB RX6800 16 GB  🐧 Manjaro + OpenSUSE Tumbleweed + ElementaryOS
VW 2023 ARCH US
🇪🇺 Europe

Link zu diesem Kommentar

Hallo zoom

 

RW kann nur quadratische Texturen !!!1!!elf!

Wenn man eine Rechteckige Bildtextur verwendet, verzerrt er sie zu einem Quadrat !

 

:huh: Dann mal bitte eine Textur / Renderworks Material aus der Bibliothek. Dort gibts eigentlich fast nie eine quadratische Textur und bei mir klappt es damit (und auch mit eigens erstellen) tadellos. Muss bei dir an etwas anderm liegen, rechteckige Bilder gehen zu 100%.

 

Gruss, Marc[/code]

Leiter BIM Consulting

ComputerWorks Schweiz

________________________________________

Vectorworks - Führende BIM-Spitzentechnologie und Flaggschiff der Nemetschek Gruppe

Weltweit verwirklichen über eine halbe Million Architekten und Designer grossartige Projekte mit Vectorworks!

Link zu diesem Kommentar

Tritt es vielleicht nur beim Transparenzkanal > Bild Maske auf ?


OK, hab es versucht.

 

Im Materialeditor sieht alles gut aus.

Im Diffuskanal sieht es auch im Rendering plausibel aus.

 

Aber im Maskenkanal verzieht er das Muster vom Rechteck zum Quadrat.

=> Eierlochblech.

📦 Mac Mini M1 16 GB M1  macOS 14 Sonoma PB

🗑️ Mac Pro 6c 24 GB D700  macOS 12.5 Monterey, in Rente ...
📺 PC RYZEN 3950X 64 GB RX6800 16 GB  🐧 Manjaro + OpenSUSE Tumbleweed + ElementaryOS
VW 2023 ARCH US
🇪🇺 Europe

Link zu diesem Kommentar

Hallo zoom

 

Danke für den Tipp. Ich melde es dem Hersteller, damit es mit dem nächsten Service Pack behoben werden kann.

 

Gruss, Marc

Leiter BIM Consulting

ComputerWorks Schweiz

________________________________________

Vectorworks - Führende BIM-Spitzentechnologie und Flaggschiff der Nemetschek Gruppe

Weltweit verwirklichen über eine halbe Million Architekten und Designer grossartige Projekte mit Vectorworks!

Link zu diesem Kommentar

Erstelle ein Benutzerkonto oder melde Dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde Dich hier an.

Jetzt anmelden
  • Forenstatistik

    • Themen insgesamt
      23,2Tsd
    • Beiträge insgesamt
      118,9Tsd
×
×
  • Neu erstellen...