Zum Inhalt springen

Auf Grundebene projezierter Schatten lässt Objekte "schweben"


rrabek

Empfohlene Beiträge

Hallo zusammen,
Leider ist es so das die "Grundebene" immer in einem Abstand zu einem Objekt ist sodass es immer so aussieht als würden die Objekte schweben. Auch in neuen Dokumenten wenn die Objekte auf z=0 sind.

Kennt jemand eine Lösung zu diesem Problem?

 

image.thumb.png.ab3b1efbaa2dbcb75208c116767e52f1.png

Link zu diesem Kommentar

Das war so seit VW von OpenGL auf Metal Mac und DirectX umgestellt hat.

Wurde aber so weit ich mich erinnere nach einigen Service Packs behoben.

 

Falls Du eine aktuelle VW Version von 2022oder 2023 benutzt sollte das nicht passieren.

Wenn doch, dann würde ich auf Geometrie die zu weit vom Dateiursprung entfernt ist tippen.

Falls die Geometrie am Ursprung ist ggf. vergessene Geometrieteile die weit weg sind.

 

Ansonsten, Grafikkarten/-Treiber Kompatibilität checken.

Bearbeitet von zoom

📦 Mac Mini M1 16 GB M1  macOS 14 Sonoma PB

🗑️ Mac Pro 6c 24 GB D700  macOS 12.5 Monterey, in Rente ...
📺 PC RYZEN 3950X 64 GB RX6800 16 GB  🐧 Manjaro + OpenSUSE Tumbleweed + ElementaryOS
VW 2023 ARCH US
🇪🇺 Europe

Link zu diesem Kommentar

Ich habe alle Treiber und VW aktualisiert. Leider Tritt das Problem immernoch auf auch wenn ich ein komplett neues Dokument erstelle und am Nullpunkt einen Extrusionsköper erzeuge.

Im Bild sieht man die Auswirkungen nochmal besser. Der 3D-Punkt ist auf 0/0/0. 



image.thumb.png.dfb38367ed268a2556955abccde68a08.png

Link zu diesem Kommentar

Vielen dank für den Tipp. Jedoch hat es nichts gebracht. 
Ich habe eben geschaut ob das Problem an einem anderen Rechner auftritt.
Und ja das Problem tritt an einem Anderen Rechhner genau so auf.
Dann scheint es wohl die Art und Weise zu sein wie ich den schatten erzeuge:

1. Exktrusion eines Objektes
2. Lichtquelle mittels "Sonnenstand" Werkzeug erstellt
3. Darstellungsart Volumenmodell mit der Einstellung "Schatten nur auf Grundebene"

 

 

Link zu diesem Kommentar

Update: Über einen Umweg habe ich eine vorrübergehende Lösung gefunden.

Mittels Shadowcatcher-Textur habe ich eine Grundebene erzeugt auf der der Schatten richtig dargestellt wird, jedoch selber unsichtbar ist.

Im Layout habe ich dann 2 Ansichtsberiche
1. Oben: Die erzeugten Schatten (durch den Shadowcatcher ist alles andere transparent)
2. Unten: Der Plan dem der Schatten fehlt
 

 

image.png

Bearbeitet von rrabek
Link zu diesem Kommentar
vor 6 Stunden schrieb rrabek:

"Schatten nur auf Grundebene"

 

Hab ich ja noch nie verwendet. Wofür ist das gut ?

Damit schaut's bei mir auch so aus.

Wenn es aus ist ist alles knorke.

 

Man braucht aber für Schatten echte 3D Geometrie.

Rechtecke o.Ä. reichen dafür nicht.

Ich habe aber immer mindestens eine fake Bodenplatte oder gleich

ein Geländemodell darunter. Ist eigentlich das erste was ich mache

bevor ich überhaupt loslege. Bzw ist schon in meinen Vorlagedateien.

 

  • Like 1

📦 Mac Mini M1 16 GB M1  macOS 14 Sonoma PB

🗑️ Mac Pro 6c 24 GB D700  macOS 12.5 Monterey, in Rente ...
📺 PC RYZEN 3950X 64 GB RX6800 16 GB  🐧 Manjaro + OpenSUSE Tumbleweed + ElementaryOS
VW 2023 ARCH US
🇪🇺 Europe

Link zu diesem Kommentar

Erstelle ein Benutzerkonto oder melde Dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde Dich hier an.

Jetzt anmelden
  • Forenstatistik

    • Themen insgesamt
      23,6Tsd
    • Beiträge insgesamt
      121,7Tsd
×
×
  • Neu erstellen...