Zum Inhalt springen

VWX 2022 - schlechte Grafik-Performance, wenn externe Monitore NICHT angeschlossen sind


BO-

Empfohlene Beiträge

Hallo,

 

ich habe kürzlich VWX 2022 auf meinem Laptop installiert und arbeite im Büro mit 2 externen Bildschirmen (- Laptop ist dann zugeklappt) über eine Dockingstation.

Funktioniert auch super.

Allerdings hat VWX 2022 massive Probleme mit der Grafik-Performance, wenn diese beiden Monitore NICHT angeschlossen sind - also, wenn ich nur mit dem Laptop arbeite - z.B. im Zug oder beim Kunden.

Z.B. läuft dann das Drehen der Ansicht langsam an und beschleunigt plötzlich nach hinten raus. Mit der Maus synchrones Navigieren, Verschieben oder Zeichnen ist dann auch nicht mehr möglich (s. Film).

Sobald ich meine Monitore wieder anschließe, läuft alles wieder flüssig.

 

  • Systemanforderungen von VWX 2022 sind erfüllt
  • Das Problem taucht ausschließlich mit VWX 2022 auf, alle anderen (3D-) Anwendungen laufen gewohnt flüssig - mit oder ohne externe Monitore
  • Mit VWX 2021 lief vor ein paar Tagen ebenfalls noch alles wie gewünscht
  • Grafikkartentreiber aktualisiert, Windows aktualisiert, VWX 2022 erst über die update-Funktion "repariert", danach komplett de- und neuinstalliert - keine Besserung
  • VWX 2022 die dedizerte Grafikkarte über NVIDIA Control-Panel zugewiesen - keine Besserung
  • Displaylink-Treiber erst aktualisiert, dann komplett deinstalliert - keine Besserung

 

Ich habe überhaupt keine Idee, was das Problem sein könnte und was ich noch machen könnte, damit ich VWX 2022 auch unterwegs nutzen kann.

 

 

 

 

Link zu diesem Kommentar

Hallo mo2999,

vielen Dank für den interessanten Link. Das beschreibt tatsächlich ziemlich genau das Phänomen - auch wenn die automatische Übersetzung etwas holprig ist ;)

 

Soweit ich das verstehe regelt NVIDIA ja automatisch, ob die Anwendung mit der internen oder der dedizierten Grafikkarte ausgeführt/dargestellt wird.

Falls die automatische Erkennung von NVIDIA nicht richtig funktionierte, konnte man das Verhalten manuell anpassen.
War bei mir und vielen anderen Nutzern bei VWX2021 offensichtlich auch schon so. Deswegen hatte CW ja diese Anleitung veröffentlicht.

 

https://cw-downloads.eu/vectorworks_forum/support-tipps/Grafikkarten_zuweisen.pdf

 

Anscheinend scheint dies aber bei VWX2022 nicht mehr zu funktionieren.

Ich habe in der NVIDIA Systemsteuerung sowohl für die vectorworks2022.exe, als auch in den Globalen Einstellungen die NVIDIA Karte für OpenGL-Tätigkeiten ausgewählt, sowie Vertikale Synchronisierung deaktiviert.

 

Damit müsste der NVIDIA Karte klar sein, dass sie für die openGL-Darstellung von VWX 2022 zuständig ist.
Klappt bei mir nicht. Oder habe ich noch etwas übersehen oder falsch verstanden?

 

Anbei meine Einstellungen.

Screen3.JPG.4f7194d67488b95eae7a6b44131bd940.JPG

 

Screen2.JPG.dc02004ca044b281da6e7a8806e8132c.JPG

Link zu diesem Kommentar

Das Kontextmenü gibt es lt. NVIDIA seit dem "Windows 10 May 2020 Update (20H1)" nicht mehr und verweist auf die Windows "Grafikeinstellungen", um ein Programm zu zwingen die NVIDIA-Karte zu benutzen.

https://nvidia.custhelp.com/app/answers/detail/a_id/5035/~/run-with-graphics-processor-missing-from-context-menu%3A-change-in-process-of

 

Hier, in den Windows-Grafikeinstellungen, war und ist VXW2022 auch schon der NVIDIA-Karte zugewiesen - leider ohne Erfolg.

 

Ob ich die NVIDIA-Karte übers BIOS priorisieren kann, bzw. die interne Grafik ausschalten, schaue ich gleich mal - ist aber ja eigentlich auch nicht gewollt. Für die meisten Programme reicht die interne, stromsparende Grafik ja vollkommen aus.

Aber ich probiere es mal.

 

image.png

Link zu diesem Kommentar
vor 3 Stunden schrieb BO-:

 

Anscheinend scheint dies aber bei VWX2022 nicht mehr zu funktionieren.

Ich habe in der NVIDIA Systemsteuerung sowohl für die vectorworks2022.exe, als auch in den Globalen Einstellungen die NVIDIA Karte für OpenGL-Tätigkeiten ausgewählt, sowie Vertikale Synchronisierung deaktiviert.

 

Damit müsste der NVIDIA Karte klar sein, dass sie für die openGL-Darstellung von VWX 2022 zuständig ist.
Klappt bei mir nicht. Oder habe ich noch etwas übersehen oder falsch verstanden?

nur zur Info:

Seit Vectorworks 2022 verwendet VGM DirectX unter Windows und Metal unter MacOS. OpenGL sollte hier also keine Rolle mehr spielen. "OpenGL" Darstellung gibt es so nicht mehr.

Vectorworks Design Suite 2024 Update 3.1

MacOS 12.7

www.unlimited.co.at www.livingpool.at

Link zu diesem Kommentar

Nur so ein Gedanke, bei Laptops mit 2 Grafikeinheiten sind für die Monitoransteuerung (Bildausgabe) Display-Switches eingebaut. Davon gibt es zwei Ausführungsvarianten; einfach/günstig oder komplexer/teurer.

 

Bei der einfacheren Variante wird das Bildsignal, welches von der dedizierten Grafikkarte generiert wird, über die integrierte Grafikeinheit geführt da bspw. der Laptopmonitor selbst direkt nur mit der integrierten Grafikeinheit "verkabelt" ist. Die "teurere" Switch Variante hat eine "Weiche" die das Bildsignal direkt ohne Umweg an den Monitor senden kann.

 

Vielleicht ist das ein wenig abwegig gedacht, aber allenfalls könnte es sein dass der integrierte Monitor so angesteuert wird und dadurch irgend ein merkwürdiger Flaschenhals entsteht, die (externen) Anschlüsse aber direkt an die dedizierte Grafikeinheit angebunden sind?

 

Andererseits macht es nicht wirklich Sinn dass dann nur VW betroffen ist.

 

Wie sieht es denn mit den Energieeinstellungen aus wenn du im "Laptopmodus" bist? Ist hier auch alles auf Höchste Leistung eingestellt oder blockiert eine Energiespareinstellung allenfalls die Leistung des Grafikmoduls?

VW2023 SP8 R1 (Build 733832) Architektur

 

iMac 5K i5-6500 16GB R9 M390 2GB macOS 12.7

Ryzen 9 7900X 64GB RX 7800XT 16GB Win11

Link zu diesem Kommentar
Zitat

Andererseits macht es nicht wirklich Sinn dass dann nur VW betroffen ist.

Ja, das wundert mich auch. Zumal selbst VWX 2021 normal läuft. Irgendetwas scheint bei VWX 2022 anders zu sein.

 

Die Energieeinstellungen sind im "Laptopmodus" auf Höchster Leistung. Der Laptop ist aber auch unterwegs eigentlich auch immer am Netzteil. Irgendwelche Stromspareinstellungen  wg. Akkubetrieb kann ich ausschließen.
Der einzige Unterschied zwischen "läuft" und "läuft nicht" ist wirklich "externe Monitore angeschlossen" oder nicht angeschlossen.

Selbst, wenn 2 externe Monitore angeschlossen sind und ich dann noch zusätzlich meinen Laptop aufklappe und als 3. Monitor verwende, läuft alles flüssig.

Link zu diesem Kommentar
  • 6 Monate später...

Erstelle ein Benutzerkonto oder melde Dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde Dich hier an.

Jetzt anmelden
  • Forenstatistik

    • Themen insgesamt
      23,1Tsd
    • Beiträge insgesamt
      118,6Tsd
×
×
  • Neu erstellen...