Zum Inhalt springen

Problem mit der Darstellung von unsichtbaren Kanten


Empfohlene Beiträge

Hallo,

 

ich habe ein mehr oder weniger großes Problem mit der Darstellung von unsichtbaren Kanten bei geschnittenen Volumenkörpern.

Wenn ich die Schnittlinie ausserhalb des Körpers anlege, werden alle Kanten korrekt angezeigt, wenn sie allerdings durch den Körper verläuft (was bei einem Schnitt ja sinnvoll ist) werden keine unsichtbaren Kanten mehr gezeigt. Weder Ausschnitte im Körper, noch dahinter liegende Objekte, etc.

Die Schnitteinstellungen bei den beiden Varianten sind exakt die gleichen.

Hier ein Screenshot von einem vereinfachten Beispiel

fehlerschnitt.JPG

 

Woran kann das liegen? Bei so einem einfachen Beispiel könnte ich ja einfach die beiden Schnitte kombinieren, aber wenn ich einen Plan zeichne kann ich nicht für jeden Körper überprüfen ob jede Kante angezeigt wird, oder etwas fehlt.

 

Vielleicht ist es ja nur eine Einstellungssache. Hat jemand eine Ahnung was ich falsch mache?

 

mfg

Florian Brandstätter

Spechtenhauser Holz- und Glasbau GmbH

http://www.spechtenhauser.com

.........................................

Windows XP SP3, Intel Core2 Quad Q6600 2340GHz, 4GB RAM

Nvidia Quadro FX 1700, 512MB

Vectorworks 2008 interiorcad

Link zu diesem Kommentar

hallo spechtenhauser,

 

beim dynamischen schnitt ist es sinnvoll, wenn du 2 klassen anlegst, die die attribute deines schnittes definieren. eine klasse ist für das aussehen deiner primären schnittfläche zuständig, also dort wo sich die schnittlinie befindet. die andere klasse steuert das aussehen der verdeckten objekte.

aktiviere in der layoutebenen deinen schnitt und klicke in der info-palette auf "einstellungen". im dialogfenster "einstellungen schnitt" wählst du die option "schnittfläche einzeln anzeigen". bei "attributklasse" wählst du die klasse, die das aussehen der schnittfläche bestimmt. hierbei ist es wichtig, dass die füllung leer ist ansonsten siehst du natürlich nicht die verdeckten teile.

im bereich "objekte hinter der schnittfläche" wählst du bei "farbe" und "art" jeweils die klasse aus, die das aussehen der verdeckten teile bestimmt.

anbei noch eine abb. vom dialogfenster.

 

gruß

kim

bild37.jpg.1139f780c186b1883a16d283e8d0a19c.jpg

Windows 7/10 Prof. (x64), VW 2016/2017 Landschaft

Link zu diesem Kommentar

Hallo Kim,

 

das Problem dabei ist ja, dass dann ALLE Objekte, die hinter der Schnittlinie liegen mit diesen Einstellungen dargestellt werden.

Es werden dann zwar die vom geschnittenen Objekt verdeckten Kanten (in meinem Fall) strichliert dargestellt, aber auch die Kanten, die eigentlich sichtbar sind, aber eben hinter der Schnittlinie liegen:

fehlerschnitt2.JPG

 

So komme ich also auch nicht zum gewünschten Ergebnis

Verdeckte Objekte und Kanten gehören als unsichtbar dargestellt, nicht verdeckte als Ansicht behandelt und geschnittene als Schnittfläche - gibt es dafür wirklich keine Einstellung? Nur ein entweder oder? :(

Florian Brandstätter

Spechtenhauser Holz- und Glasbau GmbH

http://www.spechtenhauser.com

.........................................

Windows XP SP3, Intel Core2 Quad Q6600 2340GHz, 4GB RAM

Nvidia Quadro FX 1700, 512MB

Vectorworks 2008 interiorcad

Link zu diesem Kommentar
  • 2 Wochen später...

Hallo,

schon mal

-Ansichtsbereich (Schnitt) aktivieren

-Infoleiste Einstellungen klicken

 

schließlich die Schnitttiefe einstellen ausprobiert?

 

Ansonsten ist es schon warscheinlich das über die Klassensichtbarkeiten mehr oder weniger auch einzustellen (dann müssten aber die Standardeinstellungen mal verstellt worden sein).

 

Bitte probier mal und sag` Bescheid.

 

C.

Link zu diesem Kommentar

Erstelle ein Benutzerkonto oder melde Dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde Dich hier an.

Jetzt anmelden
  • Forenstatistik

    • Themen insgesamt
      20,4Tsd
    • Beiträge insgesamt
      101,2Tsd
×
×
  • Neu erstellen...