Zum Inhalt springen

Werkzeug 'Zusammenfügen' evtl. ein bug???


Empfohlene Beiträge

Hallo Kim,

 

ich kann das ehrlich gesagt nicht nachvollziehen.

Weder bei Polylinien, die ich mit der Methode Kreisbogen erzeugt habe, noch bei miteinander verbundenen einzelnen Kreisbögen bekomme ich ein fehlerhaftes Ergebnis.

Schick doch die Datei und eine genaue Beschreibung der einzelnen Arbeitsschritte, die Du machst über das Formular an den Support. Vielleicht läßt sich die Ursache ja eingrenzen.

Link zu diesem Kommentar
  • 2 Jahre später...

hallo,

 

grüsse euch ?

 

habe das gleiche problem festgestellt, als ich ein

tutorial durchgearbeitet habe. und durch langes

probieren und mit hilfe der vectorworks-hilfe, eine

mögliche (jedoch noch nicht perfekte) lösung entdeckt:

 

- einen in eine polylinie konvertieren kreisbogen anklicken

- in der infopalette kann man die punktart kontrollieren

(über die schwarzen pfeile kann von punkt zu punkt navigiert werden)

- erste punkt zeigt unter punktart: eckpunkt (markiert ein ende der polylinie)

- zweiter punkt zeigt unter punktart: kreisbogen

- dritter punkt zeigt unter punktart: eckpunkt (zweites ende der polylinie)

 

wenn man nun den zweiten punkt von kreisbogen zu bezierkurve umstellt

(ebenfalls in der infopalette) lässt sich das zusammenfügen werkzeug (dritte option)

mit einer anderen polylinie verwenden.

 

was allerdings schiefgeht ist:

der kurvenverlauf ändert sich bei der umstellung von kreisbogen zu polylinie

(habe dieses problem leider nicht lösen können, aber vermutlich gibt es keine

lösung)

 

also meinen appell an die vectorworksprogrammierer:

falls mathematisch möglich dieses problem für das nächste servicepack

angehen.

 

bzw. wie ist es möglich einen kreisbogen so in eine polylinie zu konvertieren,

dass der bogenverlauf identisch bleibt?

 

beste grüsse

 

tobi kern

 

 

ich arbeite auf mac os x 10.6.5

mit vw 2011 studiversion arch.

/  /  /  /  /

 

VW 2024 Update 5 (Build 757604)


MacBook Pro 16"  |  2023  |  M3 Max  |  128 GB Ram
macOS Sonoma 14.5

Link zu diesem Kommentar

Hallo tobiaskern,

 

mein ursprünglicher Thread bezog sich auf einen anderen Sachverhalt was das "Zusammenfügen" Tool betrifft. Zur Verdeutlichung habe ich das Bild wieder erneut hochgeladen (war scheinbar weg ...).

Ich kann zumindest sagen, dass in der neuen VW Version dieser Fehler behoben wurde jedenfalls sieht das Ergebnis nicht mehr so aus wie auf meinem Beispielbild.

 

Das Problem das du beschreibst ist allerdings nach wie vor vorhanden. Allerdings lässt sich dieses Problem auch nicht so einfach beheben (glaube ich ...), da hierfür die Polylinienfunktion grundlegend geändert werden müsste (eine Tatsache, die ich mir schon lange wünsche ...).

Die Polylinie verhält sich leider so, dass ein Kreisbogensegment sich nicht wie ein "echter" Kreisbogen verhält. Wenn man nämlich mit dem Umformen-Werkzeug versucht einen Polylinien-Kreisbogen zu verlängern, so funktioniert das nicht, da sich beim verändern der Kreisbogen sich in einer Geraden fortsetzt. Ich schätze aus diesem Grund ist es VW auch nicht mögliche mit dem Zusammenfügen-Werkzeug eine Polylinie mit Kreisbogen zu verlängern.

Die einzige Möglichkeit, die ich bisher herausgefunden habe, ist die Polylinie temporär aufzulösen, den dann entstandenen "echten" Kreisbogen zu verlängern und anschließend die Einzelelemente wieder zusammenzufügen. Mit den Shortcuts geht das auch relativ schnell, aber nichts desto trotz finde ich es nicht besonders anwenderfreundlich.

Wir müssen also weiterhin hoffen, dass Nemetschek hier mal nachbessert ...

 

Gruß

Kim

Windows 7/10 Prof. (x64), VW 2016/2017 Landschaft

Link zu diesem Kommentar

hallo,

 

grüsse euch ?

 

@ georg

 

das problem tritt nur in inkludierten kreisbögen in polylinien auf,

nicht bei "normalen" kreisbögen

 

es war nicht direkt ein tutorial. ich habe mir ein englische

buch zu 3d modelling gekauft und dort versucht einen

workflow nach zu vollziehen. (VW Designs. Vectorworks 3DCG Visualization Book)

 

 

 

@ klr

 

jetzt mit dem bild sehe ich, dass wir tatsächlich von versch.

sachverhalten ausgegangen sind.

schätze du hast recht mit der grundlegenden änderung der

polylinienfunktion. fraglich ist, ob sich dieses problem wirklich

rechnerisch/geometrisch lösen lässt.

 

man kann also nur hoffen, auf nachbesserung mit einem/r update/neuversion

 

grüsse

 

tobi kern

/  /  /  /  /

 

VW 2024 Update 5 (Build 757604)


MacBook Pro 16"  |  2023  |  M3 Max  |  128 GB Ram
macOS Sonoma 14.5

Link zu diesem Kommentar

Hallo tobiaskern,

 

klar lässt sich das lösen, in anderen Programmen geht das ja schließlich auch z.B. AutoCad.

Wie gesagt, hierfür müsste der Kreisbogen innerhalb der Polylinie eben auch ein Kreisbogen bleiben und nicht bei einer Verlängerung zu einer Geraden werden. Ehrlich gesagt habe ich von Anfang an nicht verstanden was Nemetschek sich dabei gedacht hat aus einem Kreisbogen eine Gerade werden zu lassen ... :?:

Vielleicht kann mir ja Jemand erklären welchen Sinn das hat ...

 

Gruß

Kim

Windows 7/10 Prof. (x64), VW 2016/2017 Landschaft

Link zu diesem Kommentar
  • 2 Jahre später...

guten tag

 

habe auch probleme mit den kreisbögen in einer polyline. die zu diesem thread passen.

 

ich sollte eine polylinie öffenen. jedoch löscht es mir immer gewisse punkte kreisbögen wenn ich mit erster methode zerschneiden dies versuche. kommisch ist auch, dies geschieht weit von dem punkt den ich zu öffnen versuche.

 

meine hilfsversuche waren.

-vorerst zusätzliche punkte einfügen zum stabilisieren.

-alle arten von gläten haben keinen einfluss.

-über umweg in polygon umwandel segmentiert die kontur

 

mittlerweile ist dieser eintrag 5 jahre alt und seit dem letzten eintrag sind 2 jahre vergangen.

ist dies nicht etwa das gleiche problem?

 

aber eigentlich würde ich lieber zeichnen als das in erinnerung zu rufen

 

 

in hoffnung auf einen tipp von euch

 

sam


also habe mir zu helfen gewusst. nicht besonder elegant und speditiv aber wenigsten geht es weiter.

 

hilfspunke auf auf kreisbogenpunkte gesetzt und nach dem zerschneiden bogenpunkte wieder erganzend eingesetzt.

 

bei meinem vorigen eintrag stimmte 3 versuch, in plygon umwandel, der sachverhalt nicht, sorry.

 

auf jeden fall bin ich auch der meinung dass dieses werkzeug eine überarbeitung braucht.

Topsolid Wood, Rhino, Interiorcad 2013, Win7 64 bit

 

Link zu diesem Kommentar

das zerschneiden werkzeug ist für mich auch nie die erste option, um irgendwelche 2d objekte nach genauer vorgabe zu editieren. ich empfehle hierfür grundsätzlich zuerst die menüoptionen (> menü ändern): > fläche anlegen, > flächen zusammenfügen, > schnittfläche löschen und > schnittfläche anlegen - natürlich immer in verbindung mit einem entsprechend schnell gezeichneten hilfsobjekt - einzusetzen. hierbei bleiben in aller regel dann auch die verschiedenen anfassbaren einzelpunkte der objekte (meistens) als solche erhalten. für den schnellen überblick dieser operationen ist es auch immer hilfreich die 2d-objekte mit einer farbe zu füllen - da sieht man sofort das ganze ergebnis.

VW2024 Architektur Update 5 • Artlantis 2021 • macOS 14.5

Link zu diesem Kommentar

Hallo Sam,

 

wie du bereits geschrieben hast, ist mein letzter Eintrag 2 Jahre her und mittlerweile hat sich das Polylinienwerkzeug ein wenig verändert ...

 

Dein beschriebenes Problem kann ich leider nicht reproduzieren, bei mir funktioniert alles ganz normal.

Befindet sich deine Zeichnung vllt. sehr weit entfernt vom internen Nullpunkt? VW hat ja bekanntermaßen Fehlfunktionen wenn sich die Objekte sehr weit vom internen Nullpunkt befinden.

 

Gruß

Kim

Windows 7/10 Prof. (x64), VW 2016/2017 Landschaft

Link zu diesem Kommentar

hallo kim

 

deine nachfrage freut mich.

 

bei einem kurzen versuch klappte es an meinen händsch modifizierten polylinen wie es sein sollte wenn ich sie erneut zerschneide.

 

die linie entstand mit werkzeug parallele anlegen, von mehreren objekten, die wiederum verbunden, modifiziert und geschlossen.

 

die linien waren in einem tiefenkörper. ich zeichne nur direkt neben und mit dem nullpunkt (global).

 

ich melde mich noch wenn ich zeit habe eine backup datei anzuschauen mit dem besagten problem.

 

meine jetziges problem wo ich dringend hilfe brauche ist die datenausgabe an eine cnc mit vielen vielen polylienen als werkstück kontur schiebtür-nuten und rückwand-nuten ca. 350 meter, verteilt auf 25 werkstücke, mit bezier kreisbogen und dem ganzen repertuar, alles anders.

 

heute wollten wir mit den fräsarbeiten beginnen. jedoch ist die cnc-software woodwop fast in die knie bei der datenmenge. die polylinien mit so wenig wie moglich punkten in vw gezeichnet aber in tiefenkörper enthalten wurden beim export dwg 2000 in viele einzellinien ausgegeben.

jetzt habe ich mir testlizenz von autocad 2011 installier um zu testen. bin ein klein wenig weiter gekommen, dass heisst wenn ich die linien als reine 2d exportiere habe ich wohl die selben linien mit gleich viel punkten jedoch sind diese zwischen den ankerpunkten segmentiert-----------------------------------------------------------------------lösung nach aktivieren einer linie stürzt autocad fast ab (keine Rückmeldung) jedoch ist nach 1. minute für eine linie mit umfang 15 meter ALLES SO SCHÖN RUND WIE ES SEIN SOLLTE.

 

LGM SAM

Topsolid Wood, Rhino, Interiorcad 2013, Win7 64 bit

 

Link zu diesem Kommentar

Erstelle ein Benutzerkonto oder melde Dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde Dich hier an.

Jetzt anmelden
  • Forenstatistik

    • Themen insgesamt
      23,9Tsd
    • Beiträge insgesamt
      123Tsd
×
×
  • Neu erstellen...