Jump to content

Empfohlene Beiträge

Guten Tag zusammen,

 

Wir rätseln hier mit der IT schon seit geraumer Zeit über die Leistung von Vectorworks auf unseren Systemen.

Die Performance kann man als quälend langsam beschreiben, ein effizientes Arbeiten ist kaum möglich.

Der Rechner ist nicht wirklich ausgelastet, dennoch treten massive Performance- und Darstellungsprobleme auf, bei großen als auch bei kleinen, sehr einfachen Zeichnungen.

 

Sichtbare Probleme sind folgende:

 

Screenshot 1:

- Objekte (in diesem Falle das Waldstück in der Bildmitte) werden teilweise über, teilweise unterhalb der darunterliegenden Fläche dargestellt. Fläche und Objekt befinden sich auf unterschiedlichen Ebenen, die plane Fläche hat keine Erhebungen oder sonstiges. Je nach Blickwinkel variiert der "überdeckte" Teil der Bäume.

- Flächen und Linien werden teilweise garnicht angezeigt (Siehe unterer Bildrand). Auch die Fehlenden Flächen variieren je nach Blickwinkel, Treten aber auch bspw. in Renderings auf.

 

Screenshot 2:

- Je nach Blickwinkel wird ein Teil der Ansicht stumpf nicht dargestellt.

 

Screenshot 3:

- Teilweise lassen sich 3D Ansichten im Layoutbereich garnicht rendern, so dass die Fläche weiß bleibt.

 

Wir nutzen Vectorworks 2021 mit dem aktuellsten Servicepack.

Das ganze läuft über eine VM auf unserem Server mit folgenden Eckdaten:

Intel Xeon Gold 6142 @ 2.60Ghz, 4 Kerne

NVIDIA GRID T4-2Q

16 GB RAM Arbeitsspeicher

 

Da der Rechner nicht ausgelastet ist, können wir die Leistung ausschließen und sind mit dem Latein so langsam am Ende (Siehe Screenshot "Leistung").

Hat jemand ähnlcihe Probleme bereits behoben? Was können wir tun, um die Maschinen zu optimieren?

Wir möchten ungerne auf ein anderes Programm wechseln, da VW21 ziemlich perfekt geeignet ist für unseren Anwendungsfall.

 

So macht das Arbeiten aber keinen Spaß und ist nicht ansatzweise effizient möglich..

Ich danke schon jetzt für jeglichen Input, jede Kleinigkeit hilft.

 

Viele Grüße,

Fabian

 

Vectorworks Darstellung1.PNG

Vectorworks Darstellung2.PNG

Vectorworks Darstellung3.PNG

Vectorworks Darstellung Leistung.PNG

bearbeitet von Fabian46

Diesen Beitrag teilen


Link zum Beitrag

Habt Ihr mal geprüft, ob euer Modell zu weit vom VW-Nullpunkt weg ist? Das ist ein häufiges Problem bei Darstellungs- / Renderfehlern. Würde ich bei Screenshot 2 spontan drauf tippen.

 

Alternativ: GraKa-Treiber aktuell und VW zugewiesen? Eine OnBoard-Grafik ist nicht ausreichend!


VW19 SP6R1 - VW17 SP5 R1 - MacOS Mojave 10.14.6

iMac 2019, 3,6GHz i9, 32GB Speicher, Grafik Radeon Pro 580X 8GB

ARP-Stuttgart

MacBook Air M1 16GB - VW21

Diesen Beitrag teilen


Link zum Beitrag

Danke für die Vorschläge.

Die Grafikkartentreiber sind aktuell und passend zugewiesen.

Das Problem ist, das wir aufgrund der Firmenpolitik mit Thin-Clients auf einer Virtuellen Maschine arbeiten. Da die Leistung da aber nicht vollständig ausgenutzt wird vermuten wir, das es daran nicht liegen kann..

 

Wir arbeiten sehr oft mit Georeferenzierung, deshalb liegen die Modelle oft weit weg vom Nullpunkt, ich prüfe aber mal ob das einen Unterschied macht, Danke!

 

edit:

Das Verschieben auf den Nullpunkt hat leider keine Besserung gebracht.

 

 

bearbeitet von Fabian46

Diesen Beitrag teilen


Link zum Beitrag

Wichtig ist die Entfernung zum VW Nullpunkt, nicht zum Benutzernullpunkt. Evtl liegt auch nur ein kleines Objekt sehr weit weg. Einfach mal alle Klassen und Ebenen sichtbar machen und dann Zoom auf alle Objekte. Und in den Einstellungen den VW Nullpunkt zeigen einstellen. 


VW19 SP6R1 - VW17 SP5 R1 - MacOS Mojave 10.14.6

iMac 2019, 3,6GHz i9, 32GB Speicher, Grafik Radeon Pro 580X 8GB

ARP-Stuttgart

MacBook Air M1 16GB - VW21

Diesen Beitrag teilen


Link zum Beitrag

Ich hab alles auf den VW Nullpunkt gelegt, der Benutzernullpunkt lag schon im Ursprung.

Aber abgesehen von den Darstellungsfehlern, die Performanceprobleme scheinen damit unmittelbar zusammen zu hängen und sind ehrlich gesagt der "Spielverderber" an der Sache.

 

Gibt es dahin gehend vielleicht noch Anhaltspunkte, auf die wir noch nicht gekommen sind?

Diesen Beitrag teilen


Link zum Beitrag

Von @herbieherb wurde hier ein ausgezeichneter Beitrag geschrieben

 

Zum Thema Nullpunkte wurde erst gerade kürzlich ein Support Tipp im Forum hinterlegt:

 

 

bearbeitet von temp676

VW2020 SP6 R1 (Build 580724) Architektur

MacMini 2014 OS X 10.13.6

Diesen Beitrag teilen


Link zum Beitrag

Danke für die Tipps.

Die grundlegende Organisation der Zeichnungen ist mir auch schon vor einiger Zeit in den Sinn gekommen. An diesem Hebel habe ich schon ohne große Erfolge angesetzt..

Allerdings ist die Performance auch bei wirklich sehr einfachen und kleinen Zeichnungen (im 2D Bereich) schon absolut unterirdisch. Deshalb ist an wirklich vorzeigbare, komplexere 3D Zeichnungen aktuell leider noch garnicht zu denken, auch wenn die Auslastung der Technik noch moderat scheint.

Diesen Beitrag teilen


Link zum Beitrag
vor 2 Stunden schrieb Fabian46:

Das Problem ist, das wir aufgrund der Firmenpolitik mit Thin-Clients auf einer Virtuellen Maschine arbeiten. Da die Leistung da aber nicht vollständig ausgenutzt wird vermuten wir, das es daran nicht liegen kann..

Habt ih auch mal die Dateien auf einem "normalen" Rechner probiert? Mein letzter Stand zur Virtualisierung von Vectorworks war, dass man es vermeiden soll. 🤔

Diesen Beitrag teilen


Link zum Beitrag
Gerade eben schrieb pappadam1984:

Habt ih auch mal die Dateien auf einem "normalen" Rechner probiert? Mein letzter Stand zur Virtualisierung von Vectorworks war, dass man es vermeiden soll. 🤔

 

Ja, und da liegt auch irgendwo der Knackpunkt. Wir haben die Leistung unserer VM's schon hochgeschraubt, über das Niveau der sonst benötigten "Schreibmaschinen" aber es läuft einfach nicht sauber.

Auf meinem privaten Laptop hingegen läuft es gut, das ist allerdings auch eine mobile Workstation und nur bedingt vergleichbar..

 

Leider sind wir zur Zeit durch die Firmenpolitik an unsere VM's gebunden, so dass wir händeringend nach Optimierungspotential suchen. Andere CAD Programme laufen erfahrungsgemäß virtualisiert sehr gut.

Diesen Beitrag teilen


Link zum Beitrag

Bei diversen Werkzeugen ist VW noch stark auf Single Core Leistung ausgelegt. Die Vorberechnung von OpenGL bis alles im Grafikspeicher ist, ist ebenfalls beispielsweise eine reine SingleCore Arbeit. Und da sind eure Server CPU nicht gerade die optimale Variante. Eure Xeon Gold takten nur mit niedrigen 2.6 GHz. Wie oft der Turbo mit den 3.7 GHz überhaupt einschaltet ist fraglich. Falls ich das Bild richtig interpretiere wird die CPU (6142 mit 16/32) nämlich auf insgesamt 4 VM (wenn alle gleich konfiguriert sind) pro Socket/CPU betrieben.

Allenfalls kann auch die RAM Anbindung etwas einschränken. Bei Servern werden oft etwas geringere Taktraten gefahren plus der ECC Speicher kann auch immer ein paar Taktzyklen beanspruchen.

Wie sieht es beim persistenten Speicher aus? Werden SSD (SAS) oder sogar besser NVME SSD genutzt in jedem Server oder gibts allenfalls dezentrale Storage Arrays für die VM? Werden Cache Drives genutzt für die Daten (Optane)? Wird die Hardware direkt durch geroutet in die VM's oder ist da auch noch ein share vorhanden? Die VM selbst können auch einen gewissen overhead aufweisen.


VW2020 SP6 R1 (Build 580724) Architektur

MacMini 2014 OS X 10.13.6

Diesen Beitrag teilen


Link zum Beitrag

probiere einmal die "Performance Test-Datei (was kommt bei dir raus?): 

 

Bei mir hat folgendes geholfen:

  1. VW 2021 Programmordner Zugriffsrechte: admin: auf Lesen & Schreiben gestellt
  2. VW 2021 Benutzerordner zurückgesetzt 
  3. Alle Favoriten aus dem Favoritenordner gelöscht

 


Nikolaus Fedl

VW 2021 SP3 R1, OS Big Sur, iMac, 4 GHz Intel Core i7, 32 GB, AMD Radeon R9 M295X 4096 MB, 8TB Fusion Drive. www.fedl.eu; www.gartenplanung-fedl.at; www.freiraumarchitektur.at; www.schattenbild.at; www.gartenarchitekten.at

Diesen Beitrag teilen


Link zum Beitrag
vor 14 Stunden schrieb nfedl:

probiere einmal die "Performance Test-Datei (was kommt bei dir raus?): 

 

Bei mir hat folgendes geholfen:

 

  1. VW 2021 Programmordner Zugriffsrechte: admin: auf Lesen & Schreiben gestellt
  2. VW 2021 Benutzerordner zurückgesetzt 
  3. Alle Favoriten aus dem Favoritenordner gelöscht

 

 

Die Performance Datei läuft ohne Probleme, sämtliche Benutzerordner sehen auch soweit passend aus..

 

vor 15 Stunden schrieb temp676:

Bei diversen Werkzeugen ist VW noch stark auf Single Core Leistung ausgelegt. Die Vorberechnung von OpenGL bis alles im Grafikspeicher ist, ist ebenfalls beispielsweise eine reine SingleCore Arbeit. Und da sind eure Server CPU nicht gerade die optimale Variante. Eure Xeon Gold takten nur mit niedrigen 2.6 GHz. Wie oft der Turbo mit den 3.7 GHz überhaupt einschaltet ist fraglich. Falls ich das Bild richtig interpretiere wird die CPU (6142 mit 16/32) nämlich auf insgesamt 4 VM (wenn alle gleich konfiguriert sind) pro Socket/CPU betrieben.

Allenfalls kann auch die RAM Anbindung etwas einschränken. Bei Servern werden oft etwas geringere Taktraten gefahren plus der ECC Speicher kann auch immer ein paar Taktzyklen beanspruchen.

Wie sieht es beim persistenten Speicher aus? Werden SSD (SAS) oder sogar besser NVME SSD genutzt in jedem Server oder gibts allenfalls dezentrale Storage Arrays für die VM? Werden Cache Drives genutzt für die Daten (Optane)? Wird die Hardware direkt durch geroutet in die VM's oder ist da auch noch ein share vorhanden? Die VM selbst können auch einen gewissen overhead aufweisen.

 

Wenn man sich während der Arbeit die Kerne anschaut, dann fällt nicht auf das ein Kern höher belastet wird wie die anderen, die scheinen ziemlich parallel zu laufen.

Testweise haben wir auch 12 Kerne, 32GB RAM und den vollen Grafikspeicher der NVIDIA Grid T4 aktiviert, aber selbst das brachte keine nennenswerte Besserung.

Ich werde aber mal nachfragen ob testweise eine andere CPU mit höherer Single Core Leistung aufgeschaltet werden kann, das klingt schon mal nach einem Ansatz.

 

Generell werden SSD Drives genutzt, deine weiteren Fragen überschreiten da aber meine Kentnisse. Ich bringe das aber mal an, vielleicht versteckt sich da ein weiterer Flaschenhals.

 

Diesen Beitrag teilen


Link zum Beitrag
Geschrieben (bearbeitet)
vor 1 Stunde schrieb Fabian46:

Wenn man sich während der Arbeit die Kerne anschaut, dann fällt nicht auf das ein Kern höher belastet wird

Falls dazu die Windows Leistungsanzeige dazu genutzt wird, die stimmt leider nur teilweise bzw. Sie kann ein falsches Bild vermitteln (Interpretation des Betriebssystems). Die Auslastung messen die Server wahrscheinlich über das BMC/Managementtool selbst besser.

 

vor 1 Stunde schrieb Fabian46:

Ich werde aber mal nachfragen ob testweise eine andere CPU mit höherer Single Core Leistung aufgeschaltet werden kann, das klingt schon mal nach einem Ansatz.

Ob es überhaupt hilft müsste sich dann zeigen. VM'S funktionieren schon ein wenig anders und ich habe da keine Erfahrung damit.

bearbeitet von temp676

VW2020 SP6 R1 (Build 580724) Architektur

MacMini 2014 OS X 10.13.6

Diesen Beitrag teilen


Link zum Beitrag

Die Grafikfehler, welche du beschreibst treten auf, wenn du sehr weit vom Nullpunkt entfernt arbeitest, bzw. wenn Objekte sehr weit voneinander entfernt liegen. Um trotzdem mit grossen Koordinaten/Georeferenziert zu arbeiten sind die entsprechenden Whitepapers zu beachten. Im Grunde arbeitest du dann nahe am Nullpunkt. Dieser wird aber per Georeferenzierung verortet, so dass bei Exporten bzw. bei Bedarf die echten Koordinaten angezeigt werden können.

Ob du ein Koordinatenproblem hast, kannst du überprüfen mit dem Befehl Extras - Nullpunkte - Zeichnung zum Vectorworks-Nullpunkt verschieben. Er öffnet ein Fenster in dem dir die Koordinaten des am weitesten entfernten Objekts angezeigt werden. Dieses sollte so nah, wie es die Grösse des Projektperimeters zulässt am Nullpunkt sein.

 

Als erstes musst du herausfinden, ob dein Problem an der Arbeitsweise liegt, oder an der Hardware. Im Vectorworks-Programmordner findest du einen Unterordner Beispieldateien. Öffne da z.B. mal das File Tutorial_Stadtplanung.vwx. Es enthält ein Projekt, mit ganz ähnlichen Inhalten, wie deine Screenshots. Schau mal wie es da mit der Performance klappt und gib uns Rückmeldung.


Vectorworks 2020 - Architektur - Win 10

Diesen Beitrag teilen


Link zum Beitrag

Das Verschieben auf den Nullpunkt bringt leider keine Verbesserung..

 

Performancetechnisch gibt es minimale, aber kaum wahnehmbare Unterschiede in der Beispieldatei. Das rührt aber m.M.n. eher daher, dass die Beispieldatei nicht ganz so umfangreich ist bzw. ein deutlich kleineres Gebiet abbildet. (Beispieldatei ca. 7 MB, meine Datei ca. 35 MB) Ein CAD Programm sollte aber auch mit einer 35 MB Datei keine Probleme haben.

Auf meinem privaten System läuft die Datei schließlich auch zufriedenstellend.

 

Die Darstellungsfehler tauchen leider auch in der Beipspieldatei auf, siehe Anhang.

Wie ich grade festgestellt habe, hilft ein Ändern des 3D-Symbols in einen schematischen 3D-Baum anstelle der fotorealistischen Darstellung gegen diesen Fehler.

Das kann aber auch nur ein Provisorium sein. Die Reise soll deutlich weiter in Richtung fotorealistische Darstellung gehen, leider setzt die Performance des Programms bei dem aktuellen Stand die Grenze.

VW 1.PNG

VW 2.PNG

Diesen Beitrag teilen


Link zum Beitrag
Am 6.4.2021 um 11:49 schrieb Fabian46:

Wie ich grade festgestellt habe, hilft ein Ändern des 3D-Symbols in einen schematischen 3D-Baum anstelle der fotorealistischen Darstellung gegen diesen Fehler.

Bei mir in der Datei ist bereits eine 3D Polygon Darstellung enthalten. Ich nehme einmal an bei deinem oberen Bild wird ein ausgeschnittenes Rasterbild verwendet (Bildobjekt)? Das sollte eigentlich keinen Einfluss auf die Performance haben, ausser die Bilddatei weisst eine sehr hohe Auflösung auf. (Bei mir läuft es mit Bilder sogar flüssiger).

 

Es könnte schon sein dass die VM mit den Quadros nicht optimal sind. So wie ich dich verstanden habe werden diese nicht den einzelnen VM per passthrough zugewiesen sondern geshared. Wie das ganze dann überhoupt mit den Treibern läuft weiss ich nicht. Ich habe da definitiv zu wenig Ahnung davon. Sind den in den Windows WMs überhaupt Treiber installiert für die Karten oder läuft das alles über den Host? Dann fehlen vielleicht auch einfach Funktionen die von der Hardware eigentlich vorhanden wären, aber die VM Basic Treiber nicht verarbeiten können?


VW2020 SP6 R1 (Build 580724) Architektur

MacMini 2014 OS X 10.13.6

Diesen Beitrag teilen


Link zum Beitrag

Die Polygon-Bäume sind auch bei mir Standard, ich habe die Rasterbilder lediglich getauscht um meine Zeichnung nachzuahmen und eventuell einen Fehler zu identifizieren.

Geschwindigkeitstechnisch ist beides gleich schlecht.

 

Auf unseren VM's selber sind die Treiber der Grafikkarte installiert. Das war auch der letzte Versuch das Ganze noch weiter zu optimieren. Das hat bei kleineren 2D Zeichnungen ein wenig Besserung gebracht, sobald die Zeichnung aber auch nur ansatzweise komplexer wird ist es vorbei mit dem - halbwegs - flüssigen Arbeiten.

 

Diesen Beitrag teilen


Link zum Beitrag
Geschrieben (bearbeitet)

Hallo Fabian46

Sorry trotzdem eine kleine frage: Wie greift ihr denn auf die VM zu? RTP wird ja nicht empfohlen... was für einen Hypervisor verwendet ihr? Ich denke ja nicht dass ihr direkt auf dem Server arbeitet auf welchem die VM läuft oder? Sorry evtl. eine doofe Frage aber ich kann mir nicht recht vorstellen dass es an der Hardware liegt... Und der Arbeitsplatz an welchem ihr arbeitet was ist das ein thin client oder?

Gruss vectorworker

bearbeitet von vectorworker

Windows 7, 8.1, 10

Intel i7 8086K, Nvidia GTX 1080, 64GB Ram, SSD

SurfaceBook

Vectorworks 2019 Designer

Diesen Beitrag teilen


Link zum Beitrag

Sorry sollte natürlich RDP heissen 🙂


Windows 7, 8.1, 10

Intel i7 8086K, Nvidia GTX 1080, 64GB Ram, SSD

SurfaceBook

Vectorworks 2019 Designer

Diesen Beitrag teilen


Link zum Beitrag

Ja ganz genau.

Wir arbeiten auf Thin Clients, also so gesehen nicht direkt auf dem Server.

Hypervisor kann ich dir leider nicht nennen, da müsste ich mal nachfragen.

Ich habe in anderen Büros schon oft im Homeoffice über RDP gearbeitet, hauptsächlich mit diversen 3D Konstruktions und auch Simulationsprogrammen, das klappte immer völlig problemlos.

 

Die Hardware läuft halt im groben bei meist <50% Auslastung, das scheint erstmal in Ordnung.

Diesen Beitrag teilen


Link zum Beitrag

Hallo Fabian46

Ich bin jetzt in diesem Bereich nicht so der Hirsch aber soviel ich weiss sind Grafikkarten nicht optimiert ihre Daten via TCP/IP oder was auch immer für Netzwerkprotokolle verwendet werden, weiterzugeben... Von Nvidia gibt es da (soviel ich weiss) Lösungen die das Streaming optimieren aber ich meine nicht via RDP... Ich weiss natürlich nicht wie es in den anderen Büros gelöst war aber ich meine, dass es (wenn eine Grafikkarte von der Software verwendet wird) immer Probleme beim RDP gibt... von MS gab es mal was, ich meine das war Remote FX das bei Windows Server und HyperV eingesetzt werden konnte... Nvidia hat da anscheinend auch was aber eben habe ich nie probiert... Ich würde mal in diese Richtung suchen... Was natürlich den etwas langsam getakteten Prozessor nicht beschleunigt :-)... Gruss Vectorworker


Windows 7, 8.1, 10

Intel i7 8086K, Nvidia GTX 1080, 64GB Ram, SSD

SurfaceBook

Vectorworks 2019 Designer

Diesen Beitrag teilen


Link zum Beitrag

Vielen Dank, das sind schon mal wieder viele gute Ansatzpunkte! 👍

Mal sehen, was sich da machen lässt.

Leider kommen wir wie es aussieht von den Thin Clients erstmal nicht weg, ich denke durch einen guten, alten Tower würden die meisten Probleme direkt verschwinden...

Diesen Beitrag teilen


Link zum Beitrag

Mir ist heute noch eine andere Option eingefallen. Wie sieht es eigentlich aus wenn Ihr die (wenigen) Grafikoptionen in VW mal durchschaltet? Normalerweise ändert man diese bei Einsteiger Hardware, aber vielleicht bewirkt dies etwas?

 

Am 9.10.2020 um 13:06 schrieb temp676:

Programm Einstellungen

 

Reiter Bearbeiten

Kreisauflösung auf tief

 

Reiter Anzeige

Antialiasing deaktivieren

Bestmögliche Vorschau beim Navigieren auf Gute Leistung und Kompatibilität oder Beste Kompatibilität

 

Reiter 3D

3D-Rotation auf schnell

Solid rotieren 1 über nie (oder ausprobieren)

3D-Kreisauflösung auf tief

Verdeckte Objekte beim ... aktivieren

 


VW2020 SP6 R1 (Build 580724) Architektur

MacMini 2014 OS X 10.13.6

Diesen Beitrag teilen


Link zum Beitrag

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Gast
Auf dieses Thema antworten...

×   Du hast formatierten Text eingefügt.   Formatierung jetzt entfernen

  Only 75 emoji are allowed.

×   Dein Link wurde automatisch eingebettet.   Einbetten rückgängig machen und als Link darstellen

×   Dein vorheriger Inhalt wurde wiederhergestellt.   Clear editor

×   Du kannst Bilder nicht direkt einfügen. Lade Bilder hoch oder lade sie von einer URL.

  • Forenstatistik

    • Themen insgesamt
      16.352
    • Beiträge insgesamt
      79.831
×
×
  • Neu erstellen...