Zum Inhalt springen

Flächen werden deformiert


wim_py

Empfohlene Beiträge

Auch Hallo,

 

gehörst wohl auch zu denen, die morgens zum Bäcker reinkommen, und "BRÖTCHEN" sagen, und nach dem Kauf sich umdrehen und rausgehen.... ;)

 

Kannst Du vielleicht mehr Infos durchgeben, und evtl. einen Screenshot vorher, nachher?

Viele Grüße,

sleepwalk

 

VW2010 interiorcad • C4D 11.5 • Win XP

 

Link zu diesem Kommentar

Guten Morgen

Jetzt hab ich auch noch Hunger auf frische Brötchen. Hätte ich doch gefrühstückt...

 

Hier sind zwei Screenshots "vorher/nachhher".

 

Vorher: zwei Polygone (alles 2D).

 

Nachher: Nach dem Ausführen des Befehls "Flächen zusammenfügen" fehlen an dem "Ursprungs-" Polygon die Mauervorsprünge...

 

Vielen Dank für alle Tipps!

 

Gruß

Wim

Nachher.thumb.jpg.20292f52364e95b281468dc8e1bbe511.jpg

Vorher.thumb.jpg.1dd1bd1b5d5947beb4e6e23615b0214e.jpg

Link zu diesem Kommentar

Polygon ist geschlossen. Auch umgewandelt in Polylinie, passiert trotzdem das gleiche.

(Auch bei "Schnittfläche löschen", "Fläche zerschneiden" passiert etwas ähnlich skuriles)

 

Gibt es eine max. Anzahl Punkte ? Bei dieser Fläche sind es ca. 500. Nach der Aktion nur noch 150. VW reduziert die Stützpunkte...?

 

Kann man die Aktion "Flächen zusammenfügen" nicht beliebig oft wiederholen ?

 

 

Gruß

Wim

Link zu diesem Kommentar

hier nochmal ein paar infos nach ein paar weiteren versuchen.

 

das problem tritt bei fast allen aktionen auf die die fläche betreffen (zerschneiden, zusammenfügen, etc.)

nach einem dwg export und anschließendem import funktioniert wieder alles normal. das objekt ist dann keine polylinie mehr, sondern ein polygon. (vorheriges objekt umwandeln in polygon blieb dagegen erfolglos).

 

also liegt das problem eventuell in den ursprungs dxf daten begründet , oder gibt es in VW ein problem mit polylinien /polygonen ???

 

hab zwar jetzt eine problemlösung, würde aber gerne noch die ursache wissen. noch jemand einen hinweis ?

 

gruß

wim

Link zu diesem Kommentar

Hi wim_py,

 

ich habe gestern mal eine Freiformfläche mit gefühlten 2,3mio. Punkten durch wildes rumklicken erstellt. Anschließend habe ich es versucht zu verschneiden und zu zusammenfügen.

 

Bei mir klappt alles soweit einwandfrei (wobei ich auch nicht jeden einzelenen Punkt kontrollieren kann).

Beste Grüße

IDARC

Intel Quad Q9450 2,66GHz

4GB RAM

GForce 9600GT; RAID1

XP Pro SP3

VW Arch 09

C4D Arch 11

Link zu diesem Kommentar

Hallo wim_py,

 

kann das sein dass Du evtl.direkt in dxf Dateien arbeitest?

Das könnte evtl. auch ein Grund sein, dass das nicht so richtig klappt! dxf und dwg Daten sind mit vorsicht zu genießen. Aber dazu ist schon sehr, sehr viel hier geschrieben worden. Falls das so ist, lese doch mal die Beiträge durch, die Du über die Forumssuche findest.

Kannst auch mal zum Test deine Flächen mit einer Polylinie nachfahren, und nochmal testen, ob dann deine gewünschte Aktion funktioniert.....

Viele Grüße,

sleepwalk

 

VW2010 interiorcad • C4D 11.5 • Win XP

 

Link zu diesem Kommentar

Hallo wim_py,

konnten wir bei uns auch beobachten. Tritt wohl nur auf wenn die

Flächen weiter vom Ursprung entfernt liegen, also z.B. der Plan im

Weltkoordinatensystem liegt. Sollte aber nicht sein. Ist wohl ein Bug in der 2009er.

Probier mal, testweise, die betreffenden Flächen zum Ursprung zu verschieben

und die Aktion zu wiederholen. Geht das dann?

Ansonsten bleibt vorerst nur die betreffenden gelöschten Punkte

danach wieder einzufügen.

Grüsse,

sunhinemuck

Link zu diesem Kommentar

Hi!

 

[...] Tritt wohl nur auf wenn die Flächen weiter vom Ursprung entfernt liegen' date=' also z.B. der Plan im Weltkoordinatensystem liegt.[...']

ohhhh.... bitte nicht das. Ich dachte, ich wäre davon erlöst. :o

 

Ich kenne das nur von Nemetschek 2004 (ist lt. eines Kollegen auch in neueren Versionen möglich). Dort fokussiert das Ansichtsfenster gelegentlich auf 1:100000e00 wenn ein Vermesser-DXF mit Weltkoordinaten eingelesen wird. Einzig und allein der Export als DXF und der anschließende Import derselben hilft dann. :evil:

Beste Grüße

IDARC

Intel Quad Q9450 2,66GHz

4GB RAM

GForce 9600GT; RAID1

XP Pro SP3

VW Arch 09

C4D Arch 11

Link zu diesem Kommentar

moin

 

vielen dank für die hinweise.

ich hab noch verschiedene versuche mit anderem ursprung, nullpunkt festlegen etc. ausprobiert. das problem tritt dann aber weiterhin auf.

es handelt sich hierbei um "vermesser-dxf" vom katasteramt und als problemlösung hat import, export, import geholfen. ein reimport sozusagen...

 

sammelt nemetschek vectorworks-bugs ?

 

gruß

wim

Link zu diesem Kommentar

Hallo Wim,

 

es handelt sich hierbei um "vermesser-dxf" vom katasteramt und als problemlösung hat import' date=' export, import geholfen. ein [i']re[/i]import sozusagen...

Das mit dem Reimport hatte ich bereits geschrieben und es ist imho der einzige Weg um es auch in Nemetschek zu retten.

 

sammelt nemetschek vectorworks-bugs ?

Und ich glaube nicht, dass Nemetschek Vectorworks-Bugs sammelt, vielmehr sammelt Vectorworks augenscheinlich Nemetschek-Bugs. Aber jetzt genug der Polemik, wir wollen ja das beste hoffen und immer schön lieb sein am Wochenanfang :lol:

Beste Grüße

IDARC

Intel Quad Q9450 2,66GHz

4GB RAM

GForce 9600GT; RAID1

XP Pro SP3

VW Arch 09

C4D Arch 11

Link zu diesem Kommentar
  • 1 Jahr später...

Erstelle ein Benutzerkonto oder melde Dich an, um zu kommentieren

Du musst ein Benutzerkonto haben, um einen Kommentar verfassen zu können

Benutzerkonto erstellen

Neues Benutzerkonto für unsere Community erstellen. Es ist einfach!

Neues Benutzerkonto erstellen

Anmelden

Du hast bereits ein Benutzerkonto? Melde Dich hier an.

Jetzt anmelden
  • Forenstatistik

    • Themen insgesamt
      20,4Tsd
    • Beiträge insgesamt
      101Tsd
×
×
  • Neu erstellen...