Jump to content
Fabian46

Memoryleak: Festplattenspeicher wird restlos beschrieben, Support ist ratlos

Empfohlene Beiträge

Guten Tag zusammen,

ich habe seit einiger Zeit ein merkwürdiges Problem mit Vectorworks, vom Support wurde das ganze als "Memoryleak" beschrieben und man würde sich irgendwann bei einem der nächsten Updates mal darum kümmern. Leider ist es nahezu unmöglich mit diesem "Phänomen" zu arbeiten.

 

Nun zu dem Problem:

Bei einigen Zeichnungen, nicht allen, wird während der Bearbeitung langsam im Hintergrund der Festplattenspeicher bis auf das letzte Byte gefüllt. Die Arbeit geht so eine knappe Stunde gut, dann wird das Programm extrem langsam, ein Speichern der Arbeit ist nicht mehr möglich. Bei den auffälligen Zeichnungen handelt es sich lediglich um 2D-Skizzen, teilweise <10MB in der Größe. Das Problem tritt auch bei einigen neu erstellten Zeichnungen, ganz ohne Vorlage oder andere Objekte auf und lässt sich nicht auf bestimmte Zeichnungsinhalte etc. zurück führen.

Im Windows Temp-Ordner sammeln sich mal riesige Dateien an (10-30 GB) die nach dem Schließen von Vectorworks gelöscht werden müssen, mal findet man keine Auffälligkeiten im Temp-Ordner, und der Speicherplatz wird nach dem Schließen über einige Zeit (10-30 Minuten) ohne weiteres zutun almählich wieder freigegeben.

 

Der Support konnte bisher leider nicht weiterhelfen, die Dateien wurden vom Hersteller ohne Auffälligkeiten überprüft, das "Memoryleak" konnte allerdings nachgestellt werden. Bisher gibt es keine Lösung für das Problem.

 

Vielleicht hat hier jemand etwas Ähnliches festgestellt oder kann mir weitere Ansatzpunkte liefern um dem Problem auf den Grund zu gehen.

Das ganze passiert bei Vectorworks 2020 mit dem aktuellsten Update SP4A R1 (Build 550627) auf Windows 7 Professional SP 1 (Build 7601).

 

Ich danke im Vorraus für sämtliche Ideen, Hinweise oder änhliches!

Freundliche Grüße,

Fabian

bearbeitet von Fabian46

Diesen Beitrag teilen


Link zum Beitrag
vor 26 Minuten schrieb Fabian46:

Der Support konnte bisher leider nicht weiterhelfen, die Dateien wurden vom Hersteller ohne Auffälligkeiten überprüft, das "Memoryleak" konnte allerdings nachgestellt werden. Bisher gibt es keine Lösung für das Problem.

Wenn der Suppport dies bereits nachstellen konnte werden wir im Forum wahrscheinlich kaum Möglichkeiten haben. Oder konnte er nun doch keine Auffälligkeit finden?

 

Aktuell wäre SP5 (Build 562257), aber ich glaube nicht dass dies eine Änderung bringt.

 

Wie sieht es aus mit einem Update auf Windows 10? Das SP 1 bei Windows 7 kam im Februar 2011, vor 9 Jahren, raus und seit dem 14. Januar 2020 ist der Support komplett eingestellt bei Windows 7. Es wird keine Updates, auch keine Sicherheitsupdates, mehr geben.

 

In VW gibts meiner Kenntnis nach folgende Einstellungen welche "Speicherungen" vornehmen. Aber denke nicht dass die einen solchen Fehler produzieren.

Einstellungen Programm > Bearbeiten > Ansicht der Layoutebenen sichern

Einstellungen Programm > Anzeige > Vektordaten in Pufferspeicher verwalten

Einstellungen Programm > Diverses > Protokoll führen die wären aber eigentlich nicht im temp Ordner

Einstellungen Programm > Diverses > Fehlerbericht senden speichert log Dateien, sollten aber auch nicht im temp Ordner sein

Einstellungen Dokument > Anzeige > Zustand der Ansichtsbereiche sichern

 

Einstellungen Dokument > Anzeige > Zustand der Geländemodelle sichern


VW2020 SP5 R1 (Build 562257) Architektur

MacMini 2014 OS X 10.13.6

Diesen Beitrag teilen


Link zum Beitrag

Der Support konnte den Fehler zwar mit den Dateien nachstellen, aber in den Dateien bzw. Zeichnungen keine Auffälligkeiten feststellen.. Sprich das Problem lässt sich nicht auf ein bestimmtes Objekt/Symbol o.Ä. in den betreffenden Zeichnungen zurückführen.

 

Das ist doch immerhin schon mal ein Ansastzpunkt, Danke! Werde das neue SP mal direkt installieren.

 

Wir sind hier in der Verwaltung aktuell damit zugange auf Windows 10 umzustellen, aber das dauert natürlich alles seine Zeit, deshalb hänge ich noch auf Win7 fest. Die Mühlen der Verwaltung... ;)

Die Einstellungen nehme ich mir aber mal vor und beobachte das, Danke.

Diesen Beitrag teilen


Link zum Beitrag

Hi,

 

ich hatte mit der Einstellung "Fehlerbericht senden" mal ordentliche Probleme,

seit dem stelle ich immer auf: "Keine Daten senden".

 

Bei jeder Speicherung wurden damals Unmengen an Daten geschrieben.

 

721774280_Bildschirmfoto2020-09-23um17_29_59.png.1de6fe8b29a0f4421da8e7a356281615.png


/ / / / /

 

VW 2021 SP2 R1 (Build 574483) 64-bit
VW 2020 SP5 R1 (Build 562257) 64-Bit

Macbook Pro 2019, 16"

2,4 GHz 8-Core Intel i9, 64 GB 2667 MHz DDR4, AMD Radeon Pro 5500M 8GB
macOS Catalina 10.15.7

Diesen Beitrag teilen


Link zum Beitrag

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Gast
Auf dieses Thema antworten...

×   Du hast formatierten Text eingefügt.   Formatierung jetzt entfernen

  Only 75 emoji are allowed.

×   Dein Link wurde automatisch eingebettet.   Einbetten rückgängig machen und als Link darstellen

×   Dein vorheriger Inhalt wurde wiederhergestellt.   Clear editor

×   Du kannst Bilder nicht direkt einfügen. Lade Bilder hoch oder lade sie von einer URL.

  • Forenstatistik

    • Themen insgesamt
      15.262
    • Beiträge insgesamt
      74.047
×
×
  • Neu erstellen...