Jump to content
jlsj.

Gras wird nicht dargestellt

Empfohlene Beiträge

Hallo,

 

Ich würde für mein aktuelles Projekt gern eine recht natürlich aussehende Umgebung gestalten und habe hierfür schon ein passendes Geländemodell konstruiert und darauf VBvisual-Pflanzen gesetzt. Dem Geländemodell habe ich anschließend ein Vegetations-Material zugewiesen und die Einstellung für den Gras-Shader im Materialmenü so angepasst, wie ich es brauche. Allerdings stehe ich jetzt vor dem Problem, dass mir das Gras im Rendering nicht als solches angezeigt wird, obwohl ich im "Renderworks Eigen"-Stil den Gras-Shader aktiviert habe. Gibt es eventuell noch etwas, was ich in den Rendereinstellungen übersehen haben könnte? :huh:

 

Ich würde mich über euren Rat freuen,

 

jlsj.

Diesen Beitrag teilen


Link zum Beitrag

Mir fällt gerade keine andere Einstellung mit der man den Gras Shader

deaktivieren könnte.

 

@herbieherb hatte mal ein Problem mit dem Gras,

das allerdings in seinem Fall teilweise, aber nicht überall, gerendert wurde.

Wenn ich die Testdatei gerendert habe war das Gras wo es sein soll.

Er auf Windows, ich auf Mac.

 

Ich versuche gerade mit dem Render Bitmap Tool Ausschnitte vom Bildschirm

zu rendern. Im Prinzip funktioniert bei mir das Grass.

 

Ich komme nur nicht mit dem Render Bitmap zurecht.

Schon die Indirekte Beleuchtung kam nicht voran. Wenn ausgeschaltet das

eigentliche Rendern auch nicht.

Ich hatte den Layermassstab in meiner Vorlage auf 1:1

Das setzt die RB Tool DPI wohl auf die "Orginalgrösse" um und versucht dann

irrwitzige Auflösungen zu Rendern.

Ich habe die Layer auf 1:100 umgestellt, dan geht es wieder, allerdings ist das

Bild dann auch bei 300 DPI noch unscharf.

 

Vielleicht ist es Wert Dir auch mal den Layermasstab anzuschauen.

Bzw. die Länge der Gräser im Gras Shader zu Deinen verwendeten Einheiten passt.

Vielleicht ist das Gras bei Dir ja einfach zu kurz.

Diesen Beitrag teilen


Link zum Beitrag

Es gibt wohl einen Bug mit sehr grossen Mengen an Gras und dem Threadripper-Prozessor. Bei mir hilfts, die Grasflächen in kleinere Flächen zu unterteilen.

 

Falls du keinen Threadripper Prozessor hast, ist das Problem aber wahrscheinlich ein anderes.

Diesen Beitrag teilen


Link zum Beitrag

Das Problem hatte ich auch schon, auch ohne Threadripper CPU. Ich meinte der Gras Shader wird irgendwie automatisch deaktiviert, wenn die Fläche zu gross ist, da dies extrem Speicherintensiv werden kann. Bei mir hat es funktioniert dann nur eine Fläche im Vordergrund mit dem Gras zu belegen. Ab einer gewissen Distanz ist das Gras selbst sowieso nicht mehr wirklich sichtbar und kann mit einer einfachen Textur dargestellt werden.

Diesen Beitrag teilen


Link zum Beitrag

Vielen Dank für eure Antworten!

 

@zoom: Ich habe eben noch einmal nachgeschaut, allerdings festgestelt, dass mein Layermaßstab bereits auf 1:50 festgesetzt war. Das sollte ja eigentlich ein guter Mittelwert zwischen guter Qualität und akzeptablen Renderzeiten sein. In den Einstellungen meines Gras-Materials ist die Länge auf 10 eingestellt, wobei ich Zentimeter als Einheiten eingestellt habe. Damit sollte die Graslänge ja prinzipiell realistisch dargestellt werden.

 

@herbieherb und temp676: Mein CPU ist ein Intel Core i7-7700HQ. Ich hoffe, dass es damit kein Problem gibt :/ Ich habe euren Tipp mal umgesetzt und das Geländemodell per Zerschneiden-Tool unterteilt, da es ca. 150m*160m groß ist. Die für das Rendering relevante Stelle ist jetzt nur noch 69m*29m groß. Allerdings hat auch das bisher leider nicht geholfen. Die Darstellung kann weder mit dem Renderworks-Stil, noch mit dem Renderworks-Eigen-Stil richtig gerendert werden, wobei ich im Renderworks-Eigen-Stil nach wie vor den Gras-Shader aktiviert habe.

Diesen Beitrag teilen


Link zum Beitrag

Wie gesagt, bei mir geht es.

Im Beispiel ein Ausschnitt mit 30 cm hohen Grass.

(Sieht ein bisschen wie Pelz aus ....)

 

 

Diesen Beitrag teilen


Link zum Beitrag

Die Fläche, die mit Grashalmen gerendert werden soll, ist aktuell 69m*29m* groß. Viel kleiner kann ich die Stelle leider nicht ansetzen, da ich ein Rendering quasi in Vogelperspektive machen möchte. Dafür wäre eine sichtbare Kante von gerenderten Grashalmen zu flachem Texturbild eher ungünstig.

 

Vielleicht liegt es auch an dem Material? Ich versuche dann später nochmal ein eigenes, neues Material zu erstellen und auf meine Fläche anzuwenden. Womöglich funktioniert es dann.

Diesen Beitrag teilen


Link zum Beitrag

Die Fläche, die mit Grashalmen gerendert werden soll, ist aktuell 69m*29m* groß.

Das ist bereits ziemlich gross. Betreffend System, dies hat nicht direkt mit der CPU zu tun sondern mit dem zur verfügung stehenden Speicher (sowohl RAM wie Festplatte). Beim Prozessor ist es dann höchstens eine Frage der benötigen Rechenzeit.

 

Viel kleiner kann ich die Stelle leider nicht ansetzen, da ich ein Rendering quasi in Vogelperspektive machen möchte. Dafür wäre eine sichtbare Kante von gerenderten Grashalmen zu flachem Texturbild eher ungünstig.

Hierbei stellt sich mir die Frage ob der Grasshader überhaupt zur Geltung kommen kann bzw. überhaupt sinnvoll ist? Ich gehe davon aus dass aus einer gewissen Distanz das ganze Dargestellt wird. Zb. wie hier: https://www.itg-fotoflug.de/wp-content/uploads/2016/04/luftaufnahme-von-ihrem-haus-kamera-drohne.jpg (zufällige Google-Bildsuche)

 

Der Grasshader rechnet nun die 10cm grossen Halme welche bei der Distanz dann effektiv wohl nur wenige Milimeter dargestellt werden. Aus meiner Sicht macht es mehr Sinn mit einer gewöhnlichen Textur zu Arbeiten und allenfalls per Photoshop einzelne Stellen nachzubearbeiten.

Diesen Beitrag teilen


Link zum Beitrag

Gras mit Parallaxen versatz schaut aus der Entfernung auch recht gut aus.. Den Gras-Shader benutze ich nur für nahes Gras, für weit entferntes Gras nehm ich einen kleinen Parallaxen-Versatz.

Diesen Beitrag teilen


Link zum Beitrag

Danke soweit, ich hab das Rendering jetzt nur mithilfe einer Gras-Textur gemacht und die Büroleitung war damit ziemlich zufrieden, also hat das am Ende alles gepasst :D Bei Gelegenheit werde ich vielleicht nochmal ein wenig herumprobieren und schauen, ob sich das Problem dann irgendwie lösen lässt.

 

Grüße,

 

jlsj.

Diesen Beitrag teilen


Link zum Beitrag

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.

Gast
Auf dieses Thema antworten...

×   Du hast formatierten Text eingefügt.   Formatierung jetzt entfernen

  Only 75 emoji are allowed.

×   Dein Link wurde automatisch eingebettet.   Einbetten rückgängig machen und als Link darstellen

×   Dein vorheriger Inhalt wurde wiederhergestellt.   Clear editor

×   Du kannst Bilder nicht direkt einfügen. Lade Bilder hoch oder lade sie von einer URL.

×
×
  • Neu erstellen...